Support Center

Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Won't pair

Jill Jul 05, 2014 09:46AM PDT

I have a 4s iPhone and my g grip did initially work - now even when my Bluetooth setting is on I get a message that says --- Make sure G- grip is turned on and in range-- it IS turned on and in range ---- I've hit the pair button - I've taken a paper clip to reset in between the head phone and USB outlets - not sure if I'm doing it right - I held it for awhile- help - oh and it's charged- so that's not the problem Ither. Please help :)

Up 2 rated Down
Store Support Jul 07, 2014 07:55PM PDT G-PROJECT Agent
Hi Jill!

I'm sorry to hear you are having a pairing problem with your G-GRIP. Most of these pairing issues are a result of swapping Bluetooth sources before terminating the current connection. This sometimes causes the G-GRIP to remain connected or paired to the previous audio device. That said, it sounds like the Bluetooth needs to be reset on your G-GRIP, as well as on your iPhone 4s.

• To clear the Bluetooth memory on the G-GRIP, press and hold the Pairing button for 5 seconds. This will clear all Bluetooth settings and the blue LED light on the front of the unit should start flashing, indicating that the G-GRIP is searching for a compatible Bluetooth device.

• Next you will want to go into the Bluetooth settings menu on your iPhone 4s (and any other devices you may have connected to the G-GRIP previously) and delete / 'forget this device' from the list completely.

• Now with the G-GRIP powered on, try searching for Bluetooth compatible devices under the Bluetooth settings menu of your iPhone 4s. After a few seconds it should detect the G-GRIP, at which time you can select the G-GRIP from the list and establish a new connection.

Please let me know if this solution helps. Thanks!


G-Project Support Team
Up 0 rated Down
Christopher Stewart Aug 19, 2014 11:27AM PDT
My Ipod touch and my I pad just started doing this same thing with my G-Go. when ever I search for it, it says it is off or out of range when I know it is not. I just tried it with my droid phone which has never been paired with the device before and it worked fine. all of this happened after I updated my Ipad and Ipod touch so I am guessing something changed on the software side of the house. Has anyone else run into this problem with apple devices recently?
Up 0 rated Down
Store Support Aug 19, 2014 11:32AM PDT G-PROJECT Agent
If you did update recently you may find some minor glitches with apps and services. Usually these are reported to Apple and addressed but may take a little time to be resolved.

You can also try the steps above in this thread for resetting the Bluetooth of your G-Project speaker to see if that helps resolve the issue.


G-Project Support Team
Up 0 rated Down
Cathy Feb 11, 2015 11:07AM PST
My g grip won't pair with my iPad air or iPhone 6 plus. I have tried clearing the grip by holding down the pairing button , clearing the g grip from my devices and rebooting all of the above. Any more suggestions?
Up 0 rated Down
G-Project Support Feb 11, 2015 11:08AM PST G-PROJECT Agent
Hi Cathy!

Sorry to hear you are having a connectivity problem with your G-GRIP. Can you tell me what LED are illuminated when your G-GRIP is powered on and if they are solid or blinking?


G-Support
Up 0 rated Down
sam Aug 19, 2017 07:49AM PDT
Blue Led won't turn on at all
Up 0 rated Down
G-Project Support Aug 19, 2017 07:50AM PDT G-PROJECT Agent
Hi Sam!

Sorry to hear you are having a problem with your speaker. If you can send us a direct email (support@gprojectgear.com,) I will be happy to open a ticket and review some details to see if we can get it resolved for you.

The reason I am asking you to send a direct email rather then continuing the process here is that we will need your contact information and we prefer that information is not posted here in a public thread.

Your G-Support Team

Post Your Public Answer

Your name (required)
Your email address (required)
Answer (required)

Contact Us

beee9aeb1455f2a661c87f9e550b33be@g-project.desk-mail.com
http://assets2.desk.com/
false
tweet_g_project
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete