Support Center

Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Pairing with Windows HTC 6990LVW- Solution

matt Heinemann Jul 15, 2013 10:16PM PDT

when I try to pair it, the phone will say Not Connected. The way I fixed my issue was to go turn off the G-Go. Then go to the phone, settings, Bluetooth, G-Go connection. Make sure the Bluetooth is on, delete the G-Go connection pressing on the connection and holding until a Delete menu comes up. Turn on the G-Go and hit the pairing button and wait for the G-Go connection to appear. It will say "Tap to Pair". Tap it and it should say "Connected Music". If it does not do it, do the process again. Turn the phone off and the G-Go, then turn the phone on and then the G-Go and try it again.

There are no other settings that I can see.

Up 12 rated Down
G-Project Support Dec 31, 2013 07:30AM PST G-PROJECT Agent
Hi Rick!

The G-GO does not require any drivers. All of our speakers use the standard Bluetooth protocol called A2DP. You need to make sure that your computer supports it as well, which is not dependent on the OS as much as the make and model of your computer and whether it has Bluetooth built in and if so what protocols it supports. If your Windows computer has Bluetooth with audio support, then any of our speakers will work with it.

1) Check to see if your Bluetooth drivers on your laptop are up to date.

(2) Have you been able to pair any other speakers to your laptop before?

(3) Do you have any other device with Bluetooth, like maybe a phone, that you could try pairing your G-GO speaker to just to make sure that it's working OK?
Up 6 rated Down
Paul Apr 03, 2014 06:12PM PDT
Hey everyone, I just wanted to let you know that the Bluetooth on my G-Grip wasn't working. I have an I phone 5s. I saw this comment here regarding the same problem but with a HTC product. I did the same thing he suggested by going into settings and deleting the device from my Bluetooth setting. Then I re-paired the devices adnd it worked. Thank you, Paul (Pittsburgh).

Post Your Public Answer

Your name (required)
Your email address (required)
Answer (required)

Contact Us
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
Invalid characters found